Tag Archives: coil

Magnecor KV85 HT leads – Review

The modified HAAS coils have been on now for just over six months and 12,000 miles and everything is ticking along just fine. Even so, the Capo needs a few treats every now and again, so I thought a nice … Continue reading

Posted in Electrical, Engine | Tagged , , , , , , , , , , , , , | Comments Off on Magnecor KV85 HT leads – Review

Murphy’s law working as well as ever!

Yes I put my hand up …… it was all my own fault! I just had to go and mention the Sagem coils in the last post. A real tweak on the nose of Murphy’s Law if ever there was … Continue reading

Posted in Electrical, Engine | Tagged , , , , , , , , , , , | Comments Off on Murphy’s law working as well as ever!

Almost made it to 100K Km

Yesterday was a great day, warm and a smooth running Capo to zip about on …… not so today, no siree Bob. Started her up this morning and that dreaded little EFI light started flashing away. Front coil #1 (code … Continue reading

Posted in Electrical | Tagged , , , , , , | 2 Comments

Snap-crackle-pop ….. no, not the Capo!

Well I have to say it’s been quite a stressful few weeks ….. a Capo coil failed just before I left for the UK, but as it fed a side-sparkplug the bike ran OK and so it had to languish … Continue reading

Posted in General waffle | Tagged , , , , , , , , , | Comments Off on Snap-crackle-pop ….. no, not the Capo!

Sagem coil failure ….. inevitable really

It’s official …. Moto-Abruzzo has been bitten by the infamous Caponord coil failure syndrome. It was a lovely day so a spin round the block was on the cards, the Capo fired up sweet enough before starting to flash the … Continue reading

Posted in Datalogging, Electrical | Tagged , , | 2 Comments